Archive for » January 11th, 2013 «

How to solve Util object does not match issue

Some of the person always encounter problem when they install an application or program that required perl and normally they will facing following error message:

“List :: Util object version 1.21 does not match bootstrap parameter 1.27″

How we can solve it and is it something wrong on perl version?

Well, the answer is nothing related to perl and you just need to do the following and it should be able to make your installation smooth enough.

1)  First, you need to go to the src path using command cd /usr/local/src

2) After that, you need to download the list utils (wget http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Scalar-List-Utils-1.25.tar.gz)

3) Extract is using command tar -zxvf Scalar-List-Utils-1.25.tar.gz

4) Enter to the folder (cd Scalar-List-Utils-1.25)

5) Configure it using command perl Makefile.PL

6) Type gmake

7) Test on it by gmake test

8) Finally install it using command gmake install

Bravo! You should be able to see the error was gone. :)